const regex = /^```(.*)[a-z]*\n[\s\S]*?\n```/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^```(.*)[a-z]*\\n[\\s\\S]*?\\n```', 'g')
const str = `\`\`\`markdown
## Hello
This is my new code:
\`\`\`
Test
\`\`\`
\`\`\` <<< tutaj powinno zakonczyć matchowanie
notatki:
^.*?\\b(one|two|three)\\b.*\$
^[\`\`\`](.*)\\s*([^]+?.*?[^]+?[^]+?)\`\`
^\`\`(.*)\\s*([^]+?.*?[^]+?[^]+?)\`\`
fghfgh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}