// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^```(.*)[a-z]*\n[\s\S]*?\n```").unwrap();
let string = "```markdown
## Hello
This is my new code:
```
Test
```
``` <<< tutaj powinno zakonczyć matchowanie
notatki:
^.*?\\b(one|two|three)\\b.*$
^[```](.*)\\s*([^]+?.*?[^]+?[^]+?)``
^``(.*)\\s*([^]+?.*?[^]+?[^]+?)``
fghfgh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}