const regex = /^(?>[PQRSW]{1}-?\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\d{7}-?\d{1})$|^(?>[CDFGJNU]{1}-?\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\d{5}-?[A-Z]{1})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>[PQRSW]{1}-?\\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\\d{7}-?\\d{1})$|^(?>[CDFGJNU]{1}-?\\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\\d{5}-?[A-Z]{1})$', 'gm')
const str = `España - CIF / NIF jurídico - format validator (only format, no control digit)
P1234567A
P12345670
A12345670
A1234567A
C1234567-A
C12345670
W0034567A
W00345670`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}