$re = '/^(?>[PQRSW]{1}-?\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\d{7}-?\d{1})$|^(?>[CDFGJNU]{1}-?\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\d{5}-?[A-Z]{1})$/m';
$str = 'España - CIF / NIF jurídico - format validator (only format, no control digit)
P1234567A
P12345670
A12345670
A1234567A
C1234567-A
C12345670
W0034567A
W00345670';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);