#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>[PQRSW]{1}-?\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\d{7}-?\d{1})$|^(?>[CDFGJNUV]{1}-?\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\d{5}-?[A-Z]{1})$"
Local $sString = "España - CIF / NIF jurídico - format validator (only format, no control digit)" & @CRLF & _
"P1234567A" & @CRLF & _
"P12345670" & @CRLF & _
"" & @CRLF & _
"A12345670" & @CRLF & _
"A1234567A" & @CRLF & _
"" & @CRLF & _
"C1234567-A" & @CRLF & _
"C12345670" & @CRLF & _
"" & @CRLF & _
"W0034567A" & @CRLF & _
"W00345670" & @CRLF & _
"" & @CRLF & _
"V12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")