import Foundation
let pattern = #"^(?>[PQRSW]{1}-?\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\d{7}-?\d{1})$|^(?>[CDFGJNUV]{1}-?\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\d{5}-?[A-Z]{1})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
España - CIF / NIF jurídico - format validator (only format, no control digit)
P1234567A
P12345670
A12345670
A1234567A
C1234567-A
C12345670
W0034567A
W00345670
V12345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)