$re = '/(?:\A#match|\G(?!\A))\s*\K^(# .+)\n([\s\S]+?)(?=\n# |<!--ID|\Z)/m';
$str = '#match
# Heading 1
Text of Heading 1
More text
Even more text
<!--ID: 1695748598659-->
# Heading 2
Text of Heading 2
# Heading 3
Text of Heading 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);