import Foundation
let pattern = ##"(?:\A#match|\G(?!\A))\s*\K^(# .+)\n([\s\S]+?)(?=\n# |<!--ID|\Z)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#match
# Heading 1
Text of Heading 1
More text
Even more text
<!--ID: 1695748598659-->
# Heading 2
Text of Heading 2
# Heading 3
Text of Heading 3
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)