package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b`)
var str = `97845448
9784-5448
04197845448
+554197845448
041 9784 5448`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}