# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b"
test_str = ("97845448\n"
"9784-5448\n"
"04197845448\n"
"+554197845448\n"
"041 9784 5448")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.