# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<P2 x=")[\d,-]+(?=.*<P3 x="([\d,-]+)")/\1/gm;t' <<< "<P1 x=\"-0,36935\" y=\"0,26315\"/><P2 x=\"4,29731\" y=\"0,26315\"/><P3 x=\"5,29731\" y=\"-0,40351\"/><P4 x=\"-0,36935\" y=\"-0,40351\"/>
<P1 x=\"4,64065\" y=\"0,26315\"/><P2 x=\"5,97398\" y=\"0,26315\"/><P3 x=\"5,30731\" y=\"-0,40351\"/><P4 x=\"4,64065\" y=\"-0,40351\"/>"