import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<P2 x=\")[\\d,-]+(?=.*<P3 x=\"([\\d,-]+)\")";
final String string = "<P1 x=\"-0,36935\" y=\"0,26315\"/><P2 x=\"4,29731\" y=\"0,26315\"/><P3 x=\"5,29731\" y=\"-0,40351\"/><P4 x=\"-0,36935\" y=\"-0,40351\"/>\n"
+ "<P1 x=\"4,64065\" y=\"0,26315\"/><P2 x=\"5,97398\" y=\"0,26315\"/><P3 x=\"5,30731\" y=\"-0,40351\"/><P4 x=\"4,64065\" y=\"-0,40351\"/>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}