using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+_[a-z0-9]+)";
string input = @"ALL_KW: ""call""
PRINT_KW: ""print""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}