package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([a-z]+_[a-z0-9]+)`)
var str = `ALL_KW: "call"
PRINT_KW: "print"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}