using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bx\.set\((?:\s*(?:,\s*)?(?<o>[-+]?\d*\.?\d+(?:[Ee][-+]?\d+)?|\w+(?<a>\((?:[^()]++|(?&a))*\))*|'[^'\\]*(?:\\.[^'\\]*)*'|""[^""\\]*(?:\\.[^""\\]*)*""))*\s*\)";
string input = @"ver = '1.0'
if x.set('1.2'):
p = x.set('python_version', None)
x = x.set('test_template', DEFAULT, p(x,b),
z())";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}