import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bx\\.set\\((?:\\s*(?:,\\s*)?(?<o>[-+]?\\d*\\.?\\d+(?:[Ee][-+]?\\d+)?|\\w+(?<a>\\((?:[^()]++|(?&a))*\\))*|'[^'\\\\]*(?:\\\\.[^'\\\\]*)*'|\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"))*\\s*\\)";
final String string = "ver = '1.0'\n"
+ "if x.set('1.2'):\n"
+ " p = x.set('python_version', None)\n"
+ " x = x.set('test_template', DEFAULT, p(x,b),\n"
+ " z())";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}