#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<Placemark>\s*?<name>(?:[7-9]\d|[1-2]\d\d)(?!00|50)\d\d.*?<\/Placemark>"
Local $sString = "before..." & @CRLF & _
"<Placemark>" & @CRLF & _
" <name>7700</name>" & @CRLF & _
" <description><![CDATA[converted by:</br><a href="http://gridreferencefinder.com/">GridReferenceFinder.com</a></br>]]></description>" & @CRLF & _
" <Point>" & @CRLF & _
" <coordinates>-0.99153654,52.225002,0</coordinates>" & @CRLF & _
" </Point>" & @CRLF & _
"</Placemark>" & @CRLF & _
"after..." & @CRLF & _
"---------" & @CRLF & _
"before... " & @CRLF & _
"<Placemark> " & @CRLF & _
" <name>7701</name> " & @CRLF & _
" <description><![CDATA[converted by:</br><a href="http://gridreferencefinder.com/">GridReferenceFinder.com</a></br>]]></description> " & @CRLF & _
" <Point>" & @CRLF & _
" <coordinates>-0.99153654,52.225002,0</coordinates>" & @CRLF & _
" </Point>" & @CRLF & _
"</Placemark>" & @CRLF & _
"after..." & @CRLF & _
"--------" & @CRLF & _
"before..." & @CRLF & _
"<Placemark>" & @CRLF & _
" <name>27650</name>" & @CRLF & _
" <description><![CDATA[converted by:</br><a href="http://gridreferencefinder.com/">GridReferenceFinder.com</a></br>]]></description>" & @CRLF & _
" <Point>" & @CRLF & _
" <coordinates>-0.99153654,52.225002,0</coordinates>" & @CRLF & _
" </Point>" & @CRLF & _
"</Placemark>" & @CRLF & _
"after..." & @CRLF & _
"--------" & @CRLF & _
"before..." & @CRLF & _
"<Placemark>" & @CRLF & _
" <name>27651</name>" & @CRLF & _
" <description><![CDATA[converted by:</br><a href="http://gridreferencefinder.com/">GridReferenceFinder.com</a></br>]]></description>" & @CRLF & _
" <Point>" & @CRLF & _
" <coordinates>-0.99153654,52.225002,0</coordinates>" & @CRLF & _
" </Point>" & @CRLF & _
"</Placemark>" & @CRLF & _
"after..." & @CRLF & _
"" & @CRLF & _
"end."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")