import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Placemark>\\s*?<name>(?:[7-9]\\d|[1-2]\\d\\d)(?!00|50)\\d\\d.*?<\\/Placemark>";
final String string = "before...\n"
+ "<Placemark>\n"
+ " <name>7700</name>\n"
+ " <description><![CDATA[converted by:</br><a href=\"http://gridreferencefinder.com/\">GridReferenceFinder.com</a></br>]]></description>\n"
+ " <Point>\n"
+ " <coordinates>-0.99153654,52.225002,0</coordinates>\n"
+ " </Point>\n"
+ "</Placemark>\n"
+ "after...\n"
+ "---------\n"
+ "before... \n"
+ "<Placemark> \n"
+ " <name>7701</name> \n"
+ " <description><![CDATA[converted by:</br><a href=\"http://gridreferencefinder.com/\">GridReferenceFinder.com</a></br>]]></description> \n"
+ " <Point>\n"
+ " <coordinates>-0.99153654,52.225002,0</coordinates>\n"
+ " </Point>\n"
+ "</Placemark>\n"
+ "after...\n"
+ "--------\n"
+ "before...\n"
+ "<Placemark>\n"
+ " <name>27650</name>\n"
+ " <description><![CDATA[converted by:</br><a href=\"http://gridreferencefinder.com/\">GridReferenceFinder.com</a></br>]]></description>\n"
+ " <Point>\n"
+ " <coordinates>-0.99153654,52.225002,0</coordinates>\n"
+ " </Point>\n"
+ "</Placemark>\n"
+ "after...\n"
+ "--------\n"
+ "before...\n"
+ "<Placemark>\n"
+ " <name>27651</name>\n"
+ " <description><![CDATA[converted by:</br><a href=\"http://gridreferencefinder.com/\">GridReferenceFinder.com</a></br>]]></description>\n"
+ " <Point>\n"
+ " <coordinates>-0.99153654,52.225002,0</coordinates>\n"
+ " </Point>\n"
+ "</Placemark>\n"
+ "after...\n\n"
+ "end.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}