package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.* ?)\((.*)\)`)
var str = `My Dog (101)
ACat(f023.12)
My Dog (101)
ACat ad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}