$re = '/(.* ?)\((.*)\)/m';
$str = 'My Dog (101)
ACat(f023.12)
My Dog (101)
ACat ad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);