$re = '/^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\n?=ֿ#]+?)\/?(?=\?|$)/m';
$str = 'domain.com/home/
domain.com/home/abc/
domain.com/home?param=value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);