re = /^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\n?=ֿ#]+?)\/?(?=\?|$)/m
str = 'domain.com/home/
domain.com/home/abc/
domain.com/home?param=value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end