package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+|\s+`)
var str = `Arnold Arn Besrf Degy
Asd Fgt Tghy Uigh Hjju
Arnol #$ Df`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}