using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[!-#%-*,-\/:;?@\[-\]_{}])[+-]?(?:\d+(?:\.\d*)?|\.\d+)(?=_OilA)";
string input = @"id < c(""1250.3000488281_-57.882898769379_OilA"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}