$re = '/(?<=[!-#%-*,-\/:;?@\[-\]_{}])[+-]?(?:\d+(?:\.\d*)?|\.\d+)(?=_OilA)/m';
$str = 'id < c("1250.3000488281_-57.882898769379_OilA")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);