#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img src="(?<SRC>[^"]+)" width="(?<WIDTH>[^"]*)" alt="(?<ALT>[^"]*)" title="(?<TITLE>[^"]*)" \/>"
Local $sString = "---" & @CRLF & _
"creation date: 2023-01-06 20:04" & @CRLF & _
"description: A test file" & @CRLF & _
"modification date: 2023-01-14 10:17" & @CRLF & _
"obsidianUIMode: source" & @CRLF & _
"tags:" & @CRLF & _
"- programming" & @CRLF & _
"---" & @CRLF & _
" " & @CRLF & _
"This is the child file " & @CRLF & _
" " & @CRLF & _
"# Embed2 " & @CRLF & _
" " & @CRLF & _
"Your modes, all markdown ones: " & @CRLF & _
"**1** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="The Asexual Flag" title="The Asexual Flag" /> " & @CRLF & _
"**2** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="" title="" /> " & @CRLF & _
"3 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="The Asexual Flag" title="The Asexual Flag" /> " & @CRLF & _
"4 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="The Asexual Flag" title="The Asexual Flag" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Wikilink-embeds: " & @CRLF & _
"**5**  " & @CRLF & _
"6  " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Wikilink-embeds with names: " & @CRLF & _
"**7** <img src="001%20assets/AsexualPrideFlag.png" width="" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
"8 <img src="001%20assets/AsexualPrideFlag.svg" width="" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Wikilink-embeds with sizing " & @CRLF & _
"**9** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="" title="" /> " & @CRLF & _
"10 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="" title="" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Wikilink-embeds with sizing and names " & @CRLF & _
"**11** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
"12 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Markdown-embeds: " & @CRLF & _
"**13**  " & @CRLF & _
"14  " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Markdown-embeds with names: " & @CRLF & _
"**15** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
"16 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Markdown-embeds with sizing " & @CRLF & _
"**17** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="" title="" /> " & @CRLF & _
"18 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="" title="" /> " & @CRLF & _
" " & @CRLF & _
"// " & @CRLF & _
" " & @CRLF & _
"Markdown-embeds with sizing and names " & @CRLF & _
"**19** <img src="001%20assets/AsexualPrideFlag.png" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
"20 <img src="001%20assets/AsexualPrideFlag.svg" width="100" alt="Asexual Pride Flag" title="Asexual Pride Flag" /> " & @CRLF & _
" " & @CRLF & _
"All images with at **bolded numbers** are PNG's, all others SVG's. " & @CRLF & _
" " & @CRLF & _
"# EOF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")