// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img src="(?<SRC>[^"]+)" width="(?<WIDTH>[^"]*)" alt="(?<ALT>[^"]*)" title="(?<TITLE>[^"]*)" \/>"#).unwrap();
let string = "---
creation date: 2023-01-06 20:04
description: A test file
modification date: 2023-01-14 10:17
obsidianUIMode: source
tags:
- programming
---
This is the child file
# Embed2
Your modes, all markdown ones:
**1** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"The Asexual Flag\" title=\"The Asexual Flag\" />
**2** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"\" title=\"\" />
3 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"The Asexual Flag\" title=\"The Asexual Flag\" />
4 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"The Asexual Flag\" title=\"The Asexual Flag\" />
//
Wikilink-embeds:
**5** 
6 
//
Wikilink-embeds with names:
**7** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
8 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
//
Wikilink-embeds with sizing
**9** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"\" title=\"\" />
10 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"\" title=\"\" />
//
Wikilink-embeds with sizing and names
**11** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
12 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
//
Markdown-embeds:
**13** 
14 
//
Markdown-embeds with names:
**15** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
16 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
//
Markdown-embeds with sizing
**17** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"\" title=\"\" />
18 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"\" title=\"\" />
//
Markdown-embeds with sizing and names
**19** <img src=\"001%20assets/AsexualPrideFlag.png\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
20 <img src=\"001%20assets/AsexualPrideFlag.svg\" width=\"100\" alt=\"Asexual Pride Flag\" title=\"Asexual Pride Flag\" />
All images with at **bolded numbers** are PNG's, all others SVG's.
# EOF";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}