$re = '/{{([^}]*)}}/m';
$str = '{{.registry}}
{{ if de .proxy "" }}
{{ end -}}
{{.test_client}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);