re = /{{([^}]*)}}/m
str = '{{.registry}}
{{ if de .proxy "" }}
{{ end -}}
{{.test_client}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end