using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)(\w+)::\1\s*\((?:.|\n)*?\)*([^{]+)";
string substitution = @"$1::$1()$3";
string input = @"TropicalFruitTOutput::TropicalFruitTOutput()
: dad::CRunnable()
, m_strawberry_in()
, m_watermelon_out()
#if MAX_FRUITS == (10)
, m_cherry_out()
, m_grape_out()
#endif
{
}
NationalFruitInput::NationalFruitInput()
: dad::CRunnable()
, m_banana_in()
, m_apple_out()
, m_dragronFruit(PAD_GetdragronFruitPAD_B())
{
}
SpecialFruits::SpecialFruits()
: AmazingClassType()
, m_pineapple_in()
, m_kiwi()
, m_avocado( // PRQA S 2961 # FALSEPOSITIVE QAC warning about uninitialized
// Hello world
// This is just a comment for
// testing purpose
m_apricotController.getApricotList())
{
}
using NewFruitsBase::NewFruitsBase;
public:
bool Check(const kolaInterface& kolaInterface) override
{
// Get feature setmode enabled/disabled information
const bool aa = GET_HMI_INFO(kolaInterface).m_b;
m_isActive = (aa == true);
return m_isActive;
};";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}