import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|^)(\\w+)::\\1\\s*\\((?:.|\\n)*?\\)*([^\\{]+)";
final String string = "TropicalFruitTOutput::TropicalFruitTOutput()\n"
+ " : dad::CRunnable()\n"
+ " , m_strawberry_in()\n"
+ " , m_watermelon_out()\n"
+ "#if MAX_FRUITS == (10)\n"
+ " , m_cherry_out()\n"
+ " , m_grape_out()\n"
+ "#endif\n"
+ "{\n"
+ "}\n\n"
+ "NationalFruitInput::NationalFruitInput()\n"
+ " : dad::CRunnable()\n"
+ " , m_banana_in()\n"
+ " , m_apple_out()\n"
+ " , m_dragronFruit(PAD_GetdragronFruitPAD_B())\n"
+ "{\n"
+ "}\n\n"
+ "SpecialFruits::SpecialFruits()\n"
+ " : AmazingClassType()\n"
+ " , m_pineapple_in()\n"
+ " , m_kiwi()\n"
+ " , m_avocado( // PRQA S 2961 # FALSEPOSITIVE QAC warning about uninitialized\n"
+ " // Hello world\n"
+ " // This is just a comment for\n"
+ " // testing purpose\n"
+ " m_apricotController.getApricotList())\n"
+ "{\n"
+ "}\n\n"
+ "using NewFruitsBase::NewFruitsBase;\n\n"
+ "public:\n"
+ " bool Check(const kolaInterface& kolaInterface) override\n"
+ " {\n"
+ " // Get feature setmode enabled/disabled information\n"
+ " const bool aa = GET_HMI_INFO(kolaInterface).m_b;\n\n"
+ " m_isActive = (aa == true);\n\n"
+ " return m_isActive;\n"
+ " };";
final String subst = "$1::$1()$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}