re = /Purchase Order:\s*([A-Z\d-]+)\s*Invoice/m
str = 'SVC,PRO,WL CHRGE CASE-LKKT,CI/AR Purchase Order: CLC-GT-103782 Invoice AE78060885/14.03.2022 Country of Origin: VN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end