// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Purchase Order:\s*([A-Z\d-]+)\s*Invoice").unwrap();
let string = "SVC,PRO,WL CHRGE CASE-LKKT,CI/AR Purchase Order: CLC-GT-103782 Invoice AE78060885/14.03.2022 Country of Origin: VN";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}