$re = '/\b(?:girlfriend|(\w*friend))\b/m';
$str = 'A boyfriend and girlfriend gained a friend when they asked to befriend them';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);