re = /\b(?:girlfriend|(\w*friend))\b/m
str = 'A boyfriend and girlfriend gained a friend when they asked to befriend them'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end