package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(\w*[^i])#(^$|.+?)\*(^$|.+?)\*(^$|.+?)}`)
var str = `Any words that should be{UH#sentence G*sentence H} excluded {UH#sentence A*sentence B dzqd*sentence C} {UH#sentence D*sentence E*sentence F} any other`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}