// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{(\w*[^i])#(^$|.+?)\*(^$|.+?)\*(^$|.+?)}").unwrap();
let string = "Any words that should be{UH#sentence G*sentence H} excluded {UH#sentence A*sentence B dzqd*sentence C} {UH#sentence D*sentence E*sentence F} any other";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}