package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+\d{1,2}\s?)?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}$`)
var str = `+11 (703) 678 5982
7036785982
+17036785982
703-678-5982
+55
+123-333
123-123-123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}