$re = '/^(\+\d{1,2}\s?)?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}$/m';
$str = '+11 (703) 678 5982
7036785982
+17036785982
703-678-5982
+55
+123-333
123-123-123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);