package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\x00-\xff]`)
var str = `和帅哥们一起学正则regex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}