$re = '/[^\x00-\xff]/';
$str = '和帅哥们一起学正则regex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);