$re = '/,(?=(?:[^"\n]*"[^"\n]*")*[^"\n]*$)/m';
$str = 'a,b,c,"my my, a bit of text",e
a,b,c,"[20200624T013030 Umognog Wrote] my my, a bit of text",e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);