re = /,(?=(?:[^"\n]*"[^"\n]*")*[^"\n]*$)/m
str = 'a,b,c,"my my, a bit of text",e
a,b,c,"[20200624T013030 Umognog Wrote] my my, a bit of text",e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end