package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<number>\d+) (?P<word>\w+)`)
var str = `ABC 123 Book 456 ZZZ 789 KKK XYZ`
var substitution = "\g<word> \g<number>"
fmt.Println(re.ReplaceAllString(str, substitution))
}