using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\$\$)[\w_]+(?=\$\$)|(?<=&&)[\w_]+(?=&&)";
string input = @"My $$name$$ is John, my $$surname$$ is Doe -> should return [name, surname]
My &&name&& is John, my &&surname&& is Doe -> should return again [name, surname]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}