re = /(?<=\$\$)[\w_]+(?=\$\$)|(?<=&&)[\w_]+(?=&&)/
str = 'My $$name$$ is John, my $$surname$$ is Doe -> should return [name, surname]
My &&name&& is John, my &&surname&& is Doe -> should return again [name, surname]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end