package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)[\s]*\(?(\d{4})\)?\s*$`)
var str = `Lilo & Stitch! (2014)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}