$re = '/^(.*?)[\s]*\(?(\d{4})\)?\s*$/m';
$str = 'Lilo & Stitch! (2014)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);