# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\s:\n][^:\n]*)\s+\:\s+\[\s*([^][]*)\s+]"
test_str = ("Date : [ 2010-01-01 XX:XX:XX ] Age : [ 22 ] Sex : [ M ] : [ XXX ]\n"
"Height(cm) : [ 145 ] Weight(kg) : [ 56.4 ] Race : [ Hispanic ]\n"
"Spirometry : [ restrictive pattern ]\n"
"Treatment response : [ Negative ]\n"
"Tissue volume : [ Normal ]\n"
"Tissue volume\n"
"[ Normal RV ] \n"
"Diffusing capacity : [ Normal capacity ]\n"
"FVC Liters : [ 2.22 ] FVC Liters : [ 67 ] FVC Liters : [ 3.35 ] \n"
"FEV1 Liters : [ 1.96 ] FEV1 Liters : [ 66 ] FEV1 Liters : [ 2.06 ] \n"
"FEV1 / FVC % : [ 58 ] FEV1 / FVC % : [ 62 ]\n"
"DLCO mL/mmHg/min : [ 21.5 ] DLCO mL/mmHg/min : [ 102 ]\n"
"DLCO Adj mL/mmHg/min : [ 21.5 ] DLCO Adj mL/mmHg/min : [ 102 ]\n"
"RV/TLC % : [ 22 ]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.