$re = '/^(?:(?:\d{7}|3\d{9})(?:,(?=\d)|$))+$/m';
$str = '5461500,3256990012,8122715,3148419530';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);